Ubuntu - Byly vydány bezpečnostní aktualizace kernelu

Tento týden je ve znamení velké aktualizace Linux kernelu ve většině systému Ubuntu. Již vydané verze operačního systému získaly bezpečnostní aktualizace. Aktualizace je doporučena všem uživatelům.

Aktualizace byla vydána na Ubuntu 12.04, Ubuntu 14.04, Ubuntu 15.04 a Ubuntu 15.10. Důvodem bylo zjištění napadnutelnosti systému, které mohlo lokálním útočníkům dopomoci k získání citlivých informací nebo shození systému pomocí „denial-of-service“ (DoS) útoku pomocí epoll_ctl. Dále se v kernelech objevuje opravuje bezpečnostních chyba Kernel-based Virtual Machine (KVM), která vedla k DoS útokům.

Je tedy vhodné zkontrolovat, zda máte k dispozici poslední verzi Linux kernel. Učinit tak můžete pomocí jednoduchého příkazu v terminálu. Otevřete tedy terminál pomocí CTRL + ALT + T a napište:

uname –r

Zkontrolujte, zda verze Linux kernel souhlasí s nově vydanou aktualizací:

  • Ubuntu 12.04 – linux-image-3.2.0-98 (3.2.0-98.138)
  • Ubuntu 14.04 – linux-image-3.13.0-77 (3.13.0-77.121)
  • Ubuntu 15.04 – linux-image-3.19.0-49 (3.19.0-49.55)
  • Ubuntu 15.10 – linux-image-4.2.0-27 (4.2.0-27.32)
  • Ubuntu 15.10 (Raspberry Pi 2) - linux-image-4.2.0-1022-raspi2 (4.2.0-1022.29)

Pokud tomu tak není, proveďte rovnou i aktualizaci, která by měla výše zmíněnou verzi kernelu nainstalovat. Aktualizovat můžete pomocí Centra Software nebo v terminálu pomocí příkazů:

sudo apt-get update && sudo apt-get upgrade

Po aktualizaci restartujte počítač a znovu se přesvědčte, že máte nainstalovanou správnou verzi kernelu.

 

Kompletní seznam oprav můžete najít na oficiálních webových stránkách Ubuntu security notices - http://www.ubuntu.com/usn/